Mozscape Error: Too many urls in batch

If you enter a Moz API key, and run Domain or URL Moz checks (or both), you may encounter an error where all the columns are 0s and you see this error in the column 'URL Mozscape Error':

The problem is caused due to the rate limit you have selected in the Moz API settings. Go to Account Settings -> Mozscape and it will look like this:

The query rate you have selected is causing this issue, as it is too fast. I know what you're thinking 'but I pay for a Moz account, so I have chosen the right option.'

The 'paid' option is reserved for customers who pay directly for the Moz API (see pricing) - as in $500/month minimum.

What you actually need is the query rate that Pro members get, which is one of the other options in the dropdown.

Switch to 'Pro Account: 10 URLs every 10 seconds with all metrics,' and you will be able to get data again from the Moz API.

The other option, 'Pro Account (increased): 10 URLs every 5 seconds with all metrics' is not unlocked by default with Moz. If you contact them via this link and ask them to increase the rate limit on your API account, they should be able to do this for you (this is only available to Moz Pro customers).

Either way, switching to one of the other options on that dropdown should solve your problem.