I have connected to Google Analytics, but it just returns 0s

You may find that you are able to connect your Google Analytics account, but when you run a report, all the Analytics columns will return zeros.

This basically happens when there is a disconnect between the data you are requesting (via the URLs in your list) and the data that the Google Analytics API returns.

We have found a couple of different things can cause it:

1. You Have a Default Page Set Up

In the days before people knew how to use .htaccess, Google set up a feature in Analytics to allow users to specify two URLs as the same.

Typically this might happen if your website is:

http://www.example.com

The homepage might also resolve under:

http://www.example.com/index.php

The setting, which can be found under Admin -> View -> View Settings, combines visitor stats if a user lands on either of these pages.

What this will do is add "index.php" to ALL of your URLs in Analytics. So your reports end up looking like this:

Unfortunately, this means that when you request GA data using URL Profiler, unless you specify the 'index.php' (or index.html, or whatever) in your URLs, they are not going to match up properly.

The only way around this is to append the 'index' part to the end of your URLs before you upload them to URL Profiler. Alternatively you could remove the 'Default Page' value in GA, but this will likely screw up your historical data reporting. 

2. Domain is Different in Google Analytics

This normally occurs because the domain for the URLs you have imported is different from the domain set in Google Analytics.

It is not necessarily obvious this is the case as the domain can be set in two different places. Firstly, at Property level:

And then also at View (Profile) level:

These both need to align correctly with the domain for the URLs you have imported into URL Profiler.

Make sure the correct Account, Property and View are all selected within the Google Analytics panel of URL Profiler.

If you are unsure about which View is correct, just enter one URL from the domain and ONLY select Google Analytics from the URL options - you will quickly be able to test if the View is correct and returns data, so you can try different options until it works (each will only take a few seconds).